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About This Book

In the early days of home computing, computers came with thorough documentation. They 
included a set of manuals, detailing every button, port, light, software application and 
software feature. Although this book doesn't attempt to come close to that level of detail, 
I've written it for computer users who want a reference detailed enough to help them to 
learn about Ubuntu MATE and its applications and to build their confidence and 
competence in using them to get things done. That does not mean that this book is ONLY 
for Ubuntu MATE users. Many of the applications available in Ubuntu MATE are also 
available in other flavors of Ubuntu and in other distributions (versions) of Linux. The 
applications I discuss work in the same way regardless of the operating system.

In addition to the introduction and appendices, this guide contains these sections:

 The Basics
 Personalizing Ubuntu MATE
 Adding Trusted Applications
 Installing Linux Software Applications
 Using The Applications

Creative Commons
You can share this book with anyone and make as many copies as you like. This book is 
licensed under a Creative Commons Attribution 4.0 International License. For more about 
copying and sharing this book, visit http://creativecommons.org/licenses/by/4.0/. 

Attribution and Credits

 Special thanks to Bill Smith, co-host of the Going Linux Podcast. Without his 
contributions and creative ideas, this book would not have been possible.

 Some content adapted from Ubuntu MATE Help, published by Ubuntu MATE.
 Some content adapted from the MATE Desktop User Guide, published by the 

MATE Documentation Project.
 Some content adapted from the Going Linux website, http://goinglinux.com
 Ubuntu is a trademark of Canonical Ltd.
 All other trademarks are properties of their respective owners.
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Introduction 

Ubuntu MATE Linux is an official "flavor" of Ubuntu, pronounced oŏ'boŏntoō. Ubuntu MATE
comes pre-installed with MATE, one of many desktop environments available for use with 
Linux. The name "MATE" is pronounced Ma-Tay and comes from the name of the yerba 
maté plant, native to South America. In keeping with the South American theme, you'll 
notice that many of the applications provided along with MATE have Spanish sounding 
names like Pluma and Caja. For a basic introduction to Ubuntu MATE, including how to 
obtain and install your own copy of the software, see my previous publication, "Ubuntu 
MATE: Upgrading from Windows or OSX." 

So You've Discovered Linux!

You've likely switched to Linux to be able to use software that is like your previous 
computer's software, only better. By "better" you likely mean a modern but familiar user 
experience design, easy to understand and use, designed with security built-in, and 
protection from viruses and spyware included. You want all of that included and 
upgradeable at no additional charge. You want it all to "just work" with minimal or no 
maintenance -- automatic security updates and software upgrades for both the operating 
system and all of your installed applications. You don't mind paying for software, but you 
prefer the "try before you buy" philosophy. Ubuntu MATE gives you all of that and more!

While it's is great for users who have migrated from Windows or macOS, Ubuntu MATE is 
also an excellent choice for any kind of computer user, from casual home user to 
professional software developer. That's because of its modern, functionally thought-out 
design. Ubuntu MATE is capable enough for even the most experienced computer user 
because, well, it's Linux! It has the power of every other Linux built-in. Simply put, it 
provides a practical alternative to other software that can run on your computer.

With that in mind, this book is written from the perspective that Ubuntu MATE is a typical 
modern Linux for the average computer user. Let's assume that our fictional "average user"
is someone who needs to browse the Internet, check email, use a text editor or word 
processor, and maybe read and store document files. Let's also include viewing and editing
photos, watching videos, listening to music, and subscribing to podcasts. Many of the 
examples in this book are from my own experiences using Linux.

Whether you are new to Linux, upgrading from Windows or macOS to Linux, or just 
thinking about moving to Linux, this book will provide you with practical, day-to-day advice 
on how you can use Ubuntu MATE and its applications. This book will be a guide for new 
users and a reference for all users of Linux.
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The Basics

Why Users Switch from Windows
In addition to common and well-founded concerns around security, I often get questions 
and comments from Windows users who have become more and more dissatisfied with 
Microsoft's operating system. It seems that after purchasing and installing a new version, or
more likely purchasing a new computer with the upgraded operating system pre-installed, 
those users are finding that they have to repurchase a newer version of the same software 
applications they already own, just to have it work with the upgraded version of Windows. 
Switching to online, cloud-based software applications might at first seem to be a practical 
alternative, but those applications are often less capable and at least as expensive, 
especially after a year or more of paying monthly subscription fees. To add insult to injury, 
Windows users sometimes also have to pay for new accessories like printers and security 
cameras to replace perfectly functioning older models that require software that is no longer
compatible with the ‘upgraded' version of the operating system. Because of all this, that 
promise of a 'free upgrade' from Windows 7 or 8 to Windows 10 has, in fact, turned out to 
be anything but free. In fact, it can be just as expensive as previous Windows upgrades 
have been. 

Why Users Switch from macOS
Switching to Apple's macOS (formerly OSX) doesn't get you off of the treadmill of forking 
over more and more cash for software and hardware upgrades. If anything, it accelerates 
that treadmill. Apple's recent direction with its products seems to continue the trend of ever-
more expensive products that eliminate as many of its printer, monitor, keyboard, mouse, 
and other accessory ports as possible. I suspect that expensive dongles and adapters must
be moneymakers for Apple. They've also been sealing shut the computer's case on newer 
models, eliminating the possibility of replacing or upgrading simple things like RAM, hard 
drives, and broken parts on your own. 

Ubuntu MATE Works for You, Not the Other Way Around
Neither Microsoft nor Apple will let you upgrade that perfectly-functioning computer 
hardware you purchased a few years ago, even though it has almost the same specs as 
the newest computers available today. You are told it 'isn't capable' of running modern 
software. Insultingly, your Windows computer that is supposedly incapable of running more 
modern software keeps trying to force you to upgrade to the incompatible version! 

Perhaps you'd rather learn how to optimize Linux than hunt down one more Windows hack 
or workaround to prevent your computer from doing the things it wants to do -- but you don't
want it to be doing. Maybe you just want to use your computer to get things done. You 
believe your computer should be doing work for you, and not the other way around. Ubuntu
MATE is designed to make all of that a reality!
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Modern and Full-Featured
Designed with security in mind, Ubuntu MATE is a free, full-featured, and modern computer
operating system, with an attractive and easy to understand user interface. Its update 
manager keeps both the operating system itself and all of its installed applications updated 
to the most current, most secure release. The operating system is more secure and better-
supported than operating systems that come pre-installed on most home computer 
hardware today. With modest hardware requirements, Ubuntu MATE is suitable for modern
workstations, single board computers and older hardware alike. Ubuntu MATE makes 
modern computers fast and old computers usable.

The examples and screenshots provided here are (with a couple of exceptions) from the 
most recent version of Ubuntu MATE available at the time of the writing of this book, 
Ubuntu MATE 17.10. They were created using applications available for Ubuntu MATE and
using some of the most modern computer hardware available today. In fact, the computer I 
used is the very Dell XPS 13 9360 shown in the photo, shown here.
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Personalizing Ubuntu MATE

Although you can do some basic tweaking out of the box with other operating systems, 
Linux is infinitely more configurable than Mac or Windows. Sure you can get add-on 
software to personalize your Windows desktop quite a bit, but Ubuntu MATE, and Linux 
distributions in general provide the customization tools built right in, with additional utilities 
just a few clicks away in the software repositories (free software store). What makes Linux 
so much more flexible is that it is designed to be customizable. 

So, what can you do with Ubuntu MATE? From simply changing the background desktop 
image (wallpaper) to altering the menu position, to making your desktop a virtual 
"dashboard" for displaying the health and performance of your computer's hardware, Linux 
can do it. You can even revamp the Ubuntu MATE desktop to make it look and behave 
convincingly like macOS or Windows. Covering all of the possibilities for customization 
would fill entire book of its own, so this section will simply give you some ideas as to what 
can be done, and it will be up to you to explore on your own how you can configure your 
system to make it look and work the way you want it to. 

As you learn about Ubuntu MATE, you might find it more comfortable to put things where 
you are used to finding them. Ubuntu MATE provides the unique MATE Tweak tool to do 
just that, to transform the look and feel of your computer. The MATE Tweak application is 
found in the Ubuntu MATE menus at System > Control Center > MATE Tweak, and can be 
used to quickly change how things look and feel. You can even make Ubuntu MATE look 
and work like other popular operating systems if that's what you want. Or you can give it a 
unique and distinctive look of its own so that anyone looking at your screen can tell you 
aren't using the same computer software they are! 
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Choosing and Changing Panel Layouts
One of the quickest ways to change the look and feel of Ubuntu MATE is to select a 
different panel layout using MATE Tweak. Each panel layout is distinctive and provides a 
different desktop workflow. The following descriptions and screenshots will let you see what
I mean.

In the screenshot, above, you can see that there are seven panel layout options available. 
In the pages that follow, I'll describe each, how they differ from one another, and some of 
the basic features of each. 
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Traditional (Ubuntu-MATE) Layout

When you first install Ubuntu-MATE, you'll be using its own layout, named Traditional, 
which has a classic look of Linux with a menu in the top left, clock in the top right, and a 
panel with the list of open applications at the bottom. The menu for each application 
appears at the top of the application's window in the traditional way -- that is 'traditional' if 
you are familiar with the way it's done on Microsoft's windows. You can select a different 
panel layout using the MATE Tweak "Panel" options.
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Contemporary Layout

My favorite, the Contemporary layout has the classic look of Ubuntu MATE's default 
Traditional layout, with a menu in the top left, clock in the top right, and a panel with the list 
of open applications at the bottom. A significant difference from the Traditional layout is 
that, in the Contemporary layout, each application's menu always appears in the top panel 
rather than within the individual application's window. Called the "Global Menu," this feature
was introduced for Ubuntu MATE 17.10 and is implemented in the traditional way Apple 
handles menus for its application windows.
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Redmond Layout

The Redmond layout is similar to Microsoft Windows, with a single taskbar containing a 
menu, a list of open applications, and a clock at the bottom of the screen. Each 
application's menu appears at the top of that application's window in the traditional 
Windows way. 

Another distinctive feature of the Redmond layout is the "advanced menu" that provides a 
configurable list of favorite applications as well as an optional simple list of all applications. 
This will be familiar to users of the Linux Mint distribution.
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Cupertino Layout

The Cupertino layout is similar to Apple's macOS with a panel at the top of the screen and 
a dock at the bottom. The dock is used to display the pinned and open applications, and to 
launch applications. Of course, this layout uses the Global Menu so that the application 
menus always appear in the top panel rather than on the application windows, in the 
traditional macOS way.

You'll notice one distinctive difference between the Cupertino layout's Ubuntu MATE logo 
icon in the top left corner and macOS's Apple logo icon. Instead of a small menu gives you 
access to some basic Apple system tools, the Ubuntu MATE icon gives you access to the 
entire menu of applications, utilities, and system tools. 
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Pantheon Layout

The Pantheon layout is a blend of the Contemporary layout and the Cupertino layout. It 
has both a menu in the top left and a dock at the bottom of the screen to display pinned 
and running applications. Each application's menu appears at the top of that application's 
window, just as it does in the Redmond layout.
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Mutiny Layout

If you have tried other Ubuntu flavors and you like the look of the Unity desktop, you'll find 
the Mutiny layout familiar. It mimics, as closely as possible, the Unity 7 interface used in 
traditional Ubuntu through 2017. Mutiny uses the Global Menu which displays application 
menus in the top panel and not in the application windows. Mutiny also has a dock of icons 
on the left of the screen to launch applications, show pinned applications, and show 
running applications.
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Netbook Layout

Designed specifically for small screens, the compact Netbook layout has a single taskbar, 
menu, clock, and list of open applications at the top of the screen. There is no dock or 
panel at the bottom. That way everything is accessible no matter how small your screen.

Of course, since this is Linux, with any of these seven layouts, you can move the panels to 
the sides of your screen if you like, you can add or remove a dock, and you can control 
which icons appear in the panels. You can also choose which icons display on your 
desktop, or none at all. You can control whether the windows show some animation or 
snap into position when they open. You can even change whether the window controls for 
Close, Minimize and Maximize appear on the left, like macOS, or on the right, like 
Windows. 
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Changing the Desktop Background
Most desktop environments allow you to change the background wallpaper by right-clicking
on the desktop itself, then selecting the appropriate option from the context menu that 
appears. Ubuntu MATE is no exception.

1. Right-click the desktop and choose Change Desktop Background. If you prefer, you 
can use the menus: System > Control Center > Appearance > Background.

2. Select the image you want to use. 

3. If you have a picture on your computer's hard drive that you want to use, click the Add
button, locate the file, and then click Open.

4. Your background changes immediately. Click Close.

Note: You can use the link on the lower left to download more images from the Internet. 
Always make sure you use only trusted sites to obtain new background images.
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Changing the Theme
A desktop theme can include the set of fonts and colors used on your desktop, the size and
style of icons, the size, shape and color of the borders of each window, whether there are 
3-D or animation effects, and even whether the buttons have icons. Changing your theme 
is just as easy as changing background wallpaper.

1. From the menus choose System > Control Center > Appearance > Theme.

2. Select the theme you want to use from the list. 

3. Your theme changes immediately. Click Close

Note: You can use the link on the lower left to download more themes from the Internet. 
Always make sure you use only trusted sites to obtain new themes.
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Changing the Panels
The bars at the top and bottom edges of Ubuntu MATE's Traditional Layout are called 
Panels. Apple's macOS has a menu panel at the top edge of the screen. The icons that are
typically at the bottom of a macOS desktop are actually in a dock and not truly in a panel. 
The single panel in Windows is known as the "taskbar" and is typically located at the 
bottom edge of the screen. The top and bottom panels of Ubuntu MATE can be easily 
modified in many ways and moved into a different position on the screen. You can also 
have more or fewer than two panels if you wish.

1. Right-click a blank space in the panel and choose Properties from the menu.

2. From within the dialog box, you can edit "Orientation" to choose whether you want the 
panel at the top, at the bottom, or on one of the sides of your screen.

3. You can increase the size of the panel, and its corresponding icons.

4. Choose the "Expand" checkbox to make the panel go completely across the screen. 
Uncheck it to make it behave more like a dock.

5. Use the "Show hide buttons" setting with "Expand" unchecked to make buttons appear
at either end of the panel to let you adjust its size.

6. The "Autohide" setting causes the panel to vanish when you move the mouse cursor 
away from it and reappear when your mouse reaches the edge of the screen where 
you placed the panel.

7. The "Background" tab gives you more options for the appearance of the panel, 
including the ability to make it completely transparent, a solid color, or add a graphic 
background image.

8. To add an additional panel, right-click an existing panel and choose "New Panel".

9. Right-click the new panel you just created (or any existing panel) and choose "Add to 
panel" to add launchers, monitors, and other panel items.

10.Now start over at step one, above, and edit the preferences for your shiny new panel!
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Desktop, Panel, and Menu Icons

Create Application Icons From the Menus

Ubuntu MATE makes it very easy to add icons, also referred to as shortcuts or launchers, 
to your desktop for your most frequently used applications. I'll show you how to add the 
word processor icon to your desktop. The process is exactly the same for any application 
that appears in the Ubuntu MATE menus.

These are the steps to follow:

1. Locate the application in the menu. For the word processor application, select 
Applications > Office.

2. Now locate, but do not click on the LibreOffice Writer icon.

3. Right-click on LibreOffice Writer.

4. From the context menu that appears select Add this launcher to desktop.

Note that the same context menu lets you add the icon as a shortcut icon on the top panel! 
It will appear right next to the Firefox and the Ubuntu MATE Welcome icons.

The finished launcher will appear on your desktop as shown above. You can move it 
around and place it anywhere you want on the desktop.
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Create System Icons Using MATE Tweak

If you want to create System icons for such things as your "Computer," your "Home" folder, 
the "Trash" icon, an icon to access locations on your "Network," or "Mounted Volumes" like 
USB drives and DVD drives, then Ubuntu MATE makes that easy for you, too. You simply 
use the MATE Tweak application, located in Control Center to select the icons you want to 
be displayed. The screenshot below shows your "Desktop" options. Ensure that the "Show 
Desktop Icons" setting is checked to be certain that the icons you've selected are visible on
your desktop.
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Editing the Icons in the Menu

Ubuntu MATE provides you with the ability to edit the main menu in the top panel. This can 
be very helpful if, for example, you have created a bash script that you want to launch from 
the menu like any other application. You can even give it a custom icon. 

In this example, you'll see how I added a custom icon to run a script that I use to toggle on 
and off 100% screen brightness and a sleep delay. Remember, this is just one example of 
how you can add something to the menus. You can add a menu item for a script like this, 
you can add a menu item for an application, or you can add a menu item to open a specific 
document in a word processor or other application. It's up to you. To illustrate, the 
screenshot below shows my "toggle-awake.sh" script open for editing in the Pluma text 
editor application. You may have noticed that I've switched to a brighter Pluma theme using
its Preferences settings to make the text easier to read in this book.

Note 1: If you are writing scripts, the Pluma editor is an excellent tool to use. As you can 
see by the colored text in the script above, it is designed for this with text highlighting, and 
there other similar features built-in. 

Note 2: If you create a folder named "bin" in your home folder, Ubuntu MATE recognizes 
any file you place in that folder as a potential executable program or script. If you change 
the file permissions to allow it to run as any other program. Right-click on the file in the File 
Manager, select Properties > Permissions > Allow executing file as program.
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Adding the Menu Item

1. In the menus, select System > Control Center > Menu Editor.

2. In the left panel, select the category under which you want your menu item to appear. 
For my script, I selected the "Accessories" category.

3. Click the + button and select Add Launcher to start creating your new menu item.

4. Click on the words "New Launcher" and replace the default text with the name you 
want to appear in the menu. I named mine "Awake."

5. After entering the name of the menu item, a field appears below it, for the description. 
Enter one if you wish.

6. In the "Command" field, click the folder icon at the right of the field, then navigate to, 
and open, the application or script you want to run. Alternatively, in the "Command" 
field, you can type a command as you would enter it in a terminal to run the 
application. This could simply be the name of the application, the name of your script, 
or even a long, complex command.
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7. The "Working Directory" field is in case your program or script needs to run in a 
particular directory (folder). Normally, you can leave this field blank.

8. To change the icon for the menu item, click on the question mark icon that is displayed
by default. It's a button! Choose Browse Icons if you want to use one of the system 
icons provided. You can also choose Browse Files and select your own path and icon
you want to use, then click Apply. For my example, I found a coffee cup icon that will 
work for me. 

9. Click the Save Launcher button (the icon to the right of the +) to create your menu 
item. It now appears in the list of menu items in the category you chose. You can 
change its position in the menu using the Move Up and Move Down buttons, the 
arrow buttons at the bottom left of the menu editor window.

10.Close the editor to begin using your new menu entry.

In the illustration above, you'll see my new entry in the Accessories menu right at the top. 
You'll also notice that I have added it to the top panel, next to the Ubuntu MATE Welcome 
icon, for easy access. I did that following the instructions above in the sectioned entitled 
"Create Application Icons From the Menus."
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Display Settings
Ubuntu MATE makes connecting multiple monitors and changing the resolution quite easy. 
Changing monitor preferences is accomplished by selecting System > Control Center > 
Displays in the menus. 

1. When you connect a second monitor, it will likely connect automatically. If it doesn't, 
simply click on the black rectangle that represents the second monitor and choose the 
"On" setting. When the display is switched to "On" the rectangle will be in color.

2. Select the resolution settings you prefer. The list includes all of the resolutions that the
monitor is capable of displaying. In this example, I'm using an HDMI cable to connect 
a 1080P television as a monitor. 

3. To apply the settings, click the Apply button.
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4. The new configuration is set temporarily. If you don't confirm the settings, for example,
if the settings don't work properly, after a short delay the configuration will revert to the
previous settings. 

5. Click on Keep This Configuration to confirm your changes.
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High-Resolution Monitors
At the time of the writing of this book, support for high-resolution displays (HiDPI or 4K 
displays) is still being perfected. One day it may be possible to simply plug in a 4K or even 
an 8K monitor and have it automatically configure itself correctly like 1080P displays do 
today. For now, you may find that 4K laptop screens, like the one on my Dell XPS 13, or 
external 4K monitors have tiny icons and fonts that make them difficult to see and to use. 
You can certainly change the resolution on your display to 1920x1080 (1080P) and simply 
not use its full capabilities, but this section will walk you through adjusting the settings so 
that you can take advantage of the full resolution of your beautiful 4K display and still have 
everything readable.

Before we begin modifying your screen settings, use the instructions in the previous section
to ensure that your display is set to the highest resolution available. This will be the 4K 
resolution for your monitor. Mine is shown below.
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Changing The Font Size

To change the size of the text on the screen (the font size) you will need to change some of
the appearance settings. 

1. Open Appearances Preferences by selecting System > Control Center > Appearance 
from the menus.

2. Choose the Fonts tab.

3. You'll be tempted to change the five settings for fonts individually. Don't! There's a 
way to change everything at once. Click on the Details button.

4. The default setting for "Resolution" is 96 dots per inch. Increase this to between one 
and a half and two times the size. A setting of 144 dots per inch worked well for me, 
but you may need 168 or even 192 to make the fonts more readable. You can always 
come back to this screen later to make things bigger or smaller to suit your taste in 
font size.

5. Click each of the two Close buttons to save your changes.
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Changing Icon Size

Now that the text is bigger, the icons in the panel and in the menus have also changed size
to match. However, the icons on the desktop still seem too small. Let's make them bigger. 
Believe it or not, you use the Caja file manager to manage the desktop icons. The desktop 
is what lies behind all visible items on your screen, including the icons. In Ubuntu MATE, 
you can actively use Caja and the desktop to manage how you use your computer.

1. From the menus choose Applications > System Tools > Caja. 

2. From the menus in the Caja window, select Edit > Preferences.

3. On the Views tab, under "Icon View Defaults" change the "Default zoom level" to 
150%. This will change the size of your desktop icons and the size or icons in the file 
manager windows using the Icon View.

4. Click Close.
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Change The Pointer Size

The next step is to change the size of the pointer so that it is more visible on your 4K 
screen. 

1. Select System > Control Center > Appearance from the menus and ensure that the 
Theme tab is selected.

2. Click the Customize button, and then select the Pointer tab.

3. Move the slider to the right to change the pointer size from small to one of the two 
larger settings. 

4. Click Close to save your changes.
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Modifying The Greeter

The greeter is the application that displays the login screen that appears when you first 
boot into Ubuntu MATE. A new greeter was introduced for Ubuntu MATE release 17.10 that
has all but eliminated the need to adjust these settings, but if you use an earlier release 
with a 4K screen, you've likely already noticed how tiny the login box looks. You can 
change the greeter settings in Ubuntu MATE 17.04 and earlier to make it easier to enter 
your login name and password. Here is how:

1. Select System > Control Center > LightDM GTK+ Greeter settings from the menus. 
You will be asked for your password to make these system-level changes.

2. By default, the Fonts size is set to 11. For 4K screens, you will likely want to change 
this to twice the size. You can click on the button next to the label "Font" and move the
slider to the right to increase the size, or simply type "22" into the field. Click Select to 
acknowledge your changes and then Save to save them.

The next time you log-in, the font will be larger to make it easier to see your login 
information as you enter it.
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Power Management
When I switched from Linux Mint to Ubuntu MATE 16.04 in 2016, I saw an improvement in 
battery life from 3.5 hours of continuous use to over 5 hours using exactly the same 
computer hardware. That's a 42% increase by simply switching to Ubuntu MATE! In 
addition to revealing how this is possible, in strategy four below, this section provides other 
strategies for improving the amount of time your battery-powered Linux PC can run 
unplugged.

Strategies for Improving Battery Life

Today you can install Linux on almost any computer hardware -- Mac or Windows PC. With
a computer like one from designed-for-Linux lines such as System76, Entroware, 
OpenSourcePC, or Dell XPS Developer Edition, you can be sure you'll have the "just 
works" experience with whatever version of Linux you choose to install. But whether you 
choose a computer with Linux pre-installed, or you install it on hardware you already own, 
out-of-the-box laptop battery life can sometimes be disappointing. Here are some things 
you can do to improve your laptop's longevity when you don't have a connection to AC 
power.

1. Adjust Power Management Settings

The Power Management Settings, found in the Control Panel, allows you to control when 
the computer sleeps or hibernates, and how the display behaves. Focus on the "On Battery
Power" settings. If your laptop doesn't behave when hibernating, use the "sleep" or 
"suspend" setting when closing the lid and when the computer is idle. 

In addition to using the sleep and suspend settings, reducing the backlight brightness and 
dimming the screen while idle can reduce the battery drain while operating on battery 
power.
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2. Adjust screen brightness

A laptop's biggest battery usage is typically in powering the LCD screen. The brighter the 
screen, the more power is consumed. I found that reducing backlight brightness from 100%
to about 30% provides enough illumination to see the screen comfortably except when 
outdoors, and dramatically improves battery life. That adjustment is usually controlled by 
hardware keys on your keyboard. If you can find a brightness setting that allows you to 
easily read the screen, but no brighter, then you'll extend your on-battery time for sure. 
You'll find the software-based brightness adjustment on the "On AC Power" tab. Its setting 
applies to both when you are on AC and when you are on battery. However, if you also 
choose "Reduce backlight brightness" on the "On Battery Power" tab, then when using 
battery power, your display is actually adjusted to 50% of the display brightness you 
choose.

3. Turn off what you don't use

Don't use a Bluetooth mouse, keyboard or headphones? Turn off your Bluetooth adapter 
by right-clicking on the Bluetooth icon in the top panel and selecting "Turn Bluetooth Off". 
The computer uses power searching for Bluetooth devices. Turn off similar settings for 
other devices or services (like WiFi) that you never or rarely use.
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4. Use TLP

I was surprised that switching to Ubuntu MATE provided over a 40% increase in battery 
life. It wasn't the MATE desktop environment or the Linux distribution per se that provided 
the improvement. It was TLP, an advanced power management utility for Linux. According 
to Ubuntu MATE's creator, Martin Wimpress, the 16.04 release came with the TLP 
command-line utility pre-installed and pre-configured. TLP optimizes power settings 
automatically on startup and every time you change the power source. If you use a 
distribution, or you are using a later release of Ubuntu MATE that doesn't install it by 
default, look in your software repositories for TLP. It'll likely be there, ready to install. The 
screenshot, below, shows the default configuration of TLP on my XPS 13.

5. Get a new battery

Although today's battery technology is vastly superior to that of just a few years ago, 
batteries have a finite lifetime. They don't develop a "memory" when you "top them up" like 
they used to, but they do have a limited number of full charge cycles they can handle 
before they expire. If your laptop's battery will no longer hold a charge, maybe it's time to 
replace it. Hopefully, your model allows you to do that. If not, you may be tethered to AC 
power until you can replace your computer.
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Screensaver
The concept of a screensaver was important in the days when the cathode ray tube (CRT) 
was the only type of computer monitor available. In today's world, this software that 
originally prevented a permanent image from burning into your CRT screen is used mainly 
to provide an interesting animated image on the monitor when you step away. Although the
power management settings can lock your screen, so too can the screensaver. It's your 
choice whether to use the screensaver or the power management settings to manage 
screen locking. If you don't care for an animated screensaver, you can choose to disable it 
altogether.

The screensaver settings can be found at System > Control Center > Screensaver. 

Choose from the available default images or choose to use the images you saved in your 
Pictures folder as the screensaver. You can also choose a simple blank screen or random 
images. The time setting that appears below the image preview allows you to control the 
amount of time it takes after your mouse and keyboard have been idle before the 
screensaver activates. Uncheck "Activate screensaver when computer is idle" to 
completely disable the screensaver. If you choose to use the screensaver, a check mark in 
the setting "Lock screen when screensaver is active" ensures that you must enter your 
password to dismiss the screensaver. Unchecking the box means that the screensaver will 
stop as soon as you move the mouse or type on the keyboard.
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Adding Trusted Applications

Installing Linux Software Applications
Almost every software package that is available and tested for Ubuntu MATE is available in
the online software repositories (software catalog). The concept of software repositories is 
likely not all that familiar to long-time users switching from Windows, since classic Windows
users normally had to go to a brick and mortar store, or go online to purchase new software
for the Microsoft operating system. For macOS users however, the concept of the Apple 
App Store is similar in concept to the software repositories. Both contain trusted 
applications verified to run on their respective operating systems. Unlike most software in 
the App Store, the vast majority of Linux applications are neither proprietary nor expensive.

The software repositories for Ubuntu MATE are managed, maintained and updated by the 
distribution's maintainers and are variably referred to as "the software catalog," "the 
software library," "the software center," "software sources," or simply "software 
repositories." These repositories contain almost ALL of the full-featured, free and open 
source software that has been tested for installation on Ubuntu MATE and other Ubuntu 
derivatives. And they won't put spyware and viruses on your computer!

To install software on Ubuntu MATE, you normally use the Software Boutique. You can 
also use the software center or the Synaptic package manager. (When a Linux user says 
"package" think "software package".) Software centers and package managers are 
examples of applications that are used to browse and retrieve software packages from 
software repositories. Ubuntu MATE conveniently gives you the option to install one when 
your search in the Software Boutique returns no results. 

Trusted Sources
The Ubuntu software repositories include thousands of applications in hundreds of 
categories, suitable for just about any professional or recreational pursuit, and most are 
free of charge. When you use Ubuntu MATE, those applications as well as security 
updates, driver updates, application updates, software upgrades and operating system 
upgrades are all available from trusted sources so you won't need to search the Internet for
software. No more risking malware, junkware, or ransomware as a result of downloading 
from the wrong site! Ubuntu's software catalog is the ultimate in a trusted source!

There are several ways to obtain software from the software catalog. Ubuntu MATE's own 
Software Boutique is a carefully curated selection of the best-in-class applications from the 
Ubuntu repositories, chosen because they integrate well, complement Ubuntu MATE and 
enable you to personalize your computing experience. When you first install Ubuntu MATE,
the Software Boutique is the main graphical application you will use to install software. 

Other applications are also available to explore the complete Ubuntu software catalog. You 
have full access to the entire library at any time using the command line, but in order to 
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obtain software from the complete software catalog using a graphical application that lets 
you browse through it, you will need to enable one or more of the software center 
applications from within the Software Boutique.

Note: Installing applications from the command line is discussed in a little more detail in the
section on the MATE Terminal application, below.

Software Boutique
The Software Boutique's curated selection of the most popular applications lets you:

 Select from the list of Ubuntu MATE's recommended software, tested for the 
distribution.

 Use simple tools to manage software packages installed on your system.
 Install a software center or package manager with even more powerful ways to 

obtain additional software for your computer.

To launch the Software Boutique from the menus, choose System > Administration > 
Software Boutique. 
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Other Software Centers
If you don't find what you're looking for in the Software Boutique, install one of the available
Software Centers to explore the complete Ubuntu software catalog. Choose the "More 
Software" category using the icons across the top of the Software Boutique's main window.

The selection labeled simply "Software" installs a graphical application that lets you 
browse, install and update additional software applications and system extensions from the 
Ubuntu software repositories.

The "Synaptic Package Manager" is a graphical package management application that lets 
you install software onto your computer and manage the software that is already installed. 
It allows you to search, install, upgrade, and remove packages using the software 
repositories. It also lets you add more software sources, modify repository settings, view 
changelogs, and even lock a package to a specific version.

Ubuntu MATE always has security in mind. Regardless of how you choose to install 
software, you are always asked for your password before anything can be installed. 

This is a list of some of the most popular software selections available from the 
repositories: 

 Codecs, libdvdcss2
 Dropbox for file sharing
 Gimp advanced image editor
 The Google Chrome browser
 Google Music Manager
 InSync Google Drive application
 Minecraft
 Skype for Linux
 The Steam gaming platform
 The Software application
 SpiderOakONE offsite backup
 Spotify for music
 Synaptic package manager
 Syncthing for file synchronization
 Telegram messaging app
 Ubuntu SDK
 uGet download manager
 VeraCrypt file and folder encryption
 VirtualBox 5.0 virtual machine

There is much more available. You can browse by the application's name or by function -- 
what the application does. Because the vast majority of the software available in the 
repositories is free, you can try applications and if you don't like them, or if they don't do 
what you expect them to do, you can uninstall them just as easily.
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Using The Applications

Ubuntu MATE Welcome
Developed by the Ubuntu MATE team, the Ubuntu MATE Welcome application is a utility 
that helps you to get comfortable with your new operating system. It guides you in a step-
by-step fashion through post-install configuration such as installing drivers and adding 
language support. 

Welcome introduces new users to the operating system, highlights key features of Ubuntu 
MATE, provides quick guidelines on getting started and displays the computer system's 
specifications. Welcome also introduces users to the Ubuntu MATE Community with links 
to the community forums, social networks, the Ubuntu MATE store with branded products 
for sale, and details on donating to the project.

Welcome also includes access to the Software Boutique. It is exactly the same Software 
Boutique available from the menus and is provided here for convenience.
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Getting Started: Updates & Extras

One of the first things you will want to do after you install Ubuntu MATE for the first time, or 
after upgrading to a new release, is to click on the Getting Started button in the Welcome 
application and choose the Updates & Extras topic. This walks you through some common
post-installation configuration tasks like checking for updates, adding support for audio and 
video, and adding Blu-Ray and DVD playback support. It's organized in a step-by-step 
wizard so you don't miss anything -- and you can go back at any time to undo what you've 
done, or to find something you skipped.

Don't be surprised when you are asked for your password. You are performing updates 
and installing software. Ubuntu MATE is just keeping you safe.

Clicking the Next button in the upper right of the window takes you to the next topic, 
"Drivers."
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Getting Started: Drivers

Most drivers for Linux distributions like Ubuntu MATE are already provided as part of the 
Linux kernel. The kernel is the foundational part of the operating system that makes Linux 
Linux. While a wide range of hardware is compatible with Ubuntu MATE as a result, your 
computer hardware may include components and peripherals that require proprietary 
drivers to function properly. When you were installing Ubuntu MATE, you were asked if you
wanted to download and use third-party software. If you ticked the checkbox to do that, 
clicking the Additional Drivers button reveals which, if any, proprietary drivers have 
already been installed and enabled for you. If you did not purchase your computer with 
Linux pre-installed, you may find that clicking Install Firmware Package is required to get 
some devices to work correctly.

The open source drivers for some proprietary devices, the ones provided in the kernel, are 
sometimes reverse-engineered. What that means is that the manufacturers of proprietary 
devices won't provide the specifications or the details of their own drivers to open source 
developers because they want to keep their "technology" secret. (Hence the term 
proprietary.) The developers of reverse-engineered drivers provided in Ubuntu MATE have 
made their best effort and have tested the functionality thoroughly, but sometimes there are
features that could not be reproduced and are not provided in these drivers. 
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Sometimes, though, manufacturers of proprietary devices will provide Linux-compatible 
drivers that they develop themselves. They won't let us know how their drivers work, so 
they never make it into the kernel, but where these proprietary drivers are available, they 
sometimes perform better than the reverse-engineered versions. With Ubuntu MATE, many
of the proprietary drivers that have been made available are provided in the Welcome 
application, or in Software & Update (available in the System > Administration menu) 
under the "Additional Drivers" tab. Usually, Ubuntu MATE automatically makes the best 
choice of open source or proprietary driver for your hardware when it's installed, but you 
have the choice of which driver works best for you. 

If you find that Wi-Fi, Bluetooth or other hardware does not work, and the "Additional 
Drivers" did not find alternative drivers, you may need to research your device to find the 
appropriate driver. I've provided three methods of discovering your computer's specs in the 
next section, "Displaying Your System Information."

If there is nothing there in "Additional Drivers" to improve the performance of your hardware
device, you may find something on the hardware manufacturer's site. You may need to 
install proprietary manufacturer drivers using the command line if you choose to use them. 
If you do, be careful to follow the installation instructions carefully, and before you install, 
make a system backup and understand how to uninstall just in case the proprietary drivers 
don't work. DO NOT simply search for drivers using drivers.com or other third party sites. 
When you use third party sources, there is no guarantee that you aren't getting something 
that will inject malware or corrupt your system. If you are unsure, or if you simply can't 
figure it out, you are better off asking about it in Ubuntu MATE forums and looking for 
someone else that has some advice or experience. Or you could just settle for the lower 
performance of the reverse-engineered driver. Of course, if you happen to be an expert in a
device that doesn't have drivers in the kernel, the open source community would appreciate
you sharing your expertise to help develop high-performance open source drivers for 
inclusion in the kernel.

Getting Started: Setting Up Printers

Setting up a printer is often as simple as plugging in its USB cable, or connecting it and 
your computer's Wi-Fi to your home wireless network. For more on printing see the 
"Document Management" section, below. Click on Read more on printing in the Getting 
Started window to discover Linux-compatible printers that can be detected and setup 
automatically.
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Getting Started: Additional Utilities

In "Software Utilities for Peripherals" you will find applications that you can install from the 
Ubuntu repositories to help with specific needs. 

One example that I have used is Solaar, which is a utility for pairing and unpairing Logitech 
Unifying Receivers with Logitech peripherals like mice and keyboards. Click the Install 
button below the description of the software utility you want to download and install. 
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Display Your System Information

Getting Started: System Specifications

When you move to a new operating system, whether it's Windows, macOS or a Linux OS 
that's new to you, it's sometimes difficult to find what you are looking for -- at first. Take 
finding a list of your system hardware for example. In classic Windows, if you wanted a 
graphical display of the specs for your computer, you right-clicked on the My Computer 
desktop icon and selected Properties. With Windows 10, you click the Windows logo in the 
taskbar, then select Settings > System > About. I imagine neither is very intuitive if you 
have only ever used a Mac. On Apple's OS-X, you select About This Mac from the Apple 
logo menu to get a dialog box with selections to display at least some of your computer's 
specifications. Linux, too, has graphical tools to display information about your computer's 
hardware. Ubuntu MATE provides system specifications in the Welcome application. From 
the menu, select System > Welcome > Getting Started > System Specifications. 

This graphical method presents a nice browseable list of information, but with a terminal 
and a few commands, you can really dig under the hood of your Ubuntu MATE computer's 
hardware. The remainder of this discussion describes how to use the command line to 
reveal some additional information stored in text files on your hard drive and, for the big 
finish, how to get all of your system information, all at once, by typing a single line of text 
into the terminal!
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Display your system info using "inxi"

Possibly the easiest command to use in the terminal to get a full listing of your computer's 
configuration is 

inxi -F

as shown below. For a more verbose set of information, use 

inxi -Frmxx

For just the very basic info, type simply 

inxi

The "List Hardware" Command

I've saved the best command for last. The command, lshw, is the "list hardware" command.
You can type it at the command line without any switches or options, but the text file it 
generates runs on forever, and is a little difficult to follow in the terminal. It needs to run as 
root (administrator), so you'll need to type "sudo" in front of the command. The command 
listed below runs lshw with the -html option to create an html file. Open it in a browser and 
you have a nice "web page" with all of your hardware specs. 

sudo lshw -html>myhardware.html

When I ran it, this command detected and reported on my touch screen, attached USB 
storage drives, and even the micro-SD card on the phone I had charging on a USB port!
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Ubuntu MATE Guide

The Ubuntu MATE Guide, found in the Ubuntu MATE menus at Applications > System 
Tools > Ubuntu MATE Guide, is for users needing a little extra help while learning to use 
Ubuntu MATE. The guide is divided into these main topics followed by a list of frequently 
asked questions (FAQ):

What is Ubuntu MATE Anyway?

A high-level description of Ubuntu MATE and its major applications, including:

 Definitions: Ubuntu, The MATE desktop, and Open Source
 Ubuntu MATE Welcome
 Productivity Applications
 Document Management
 Entertainment Applications
 Games
 Security
 Accessibility

About Ubuntu MATE

Objectives, hardware requirements, downloading, installing and getting support.

- 46 -



Accessibility

Accessibility is a key priority for Ubuntu MATE. When computer access is shared within a 
household or business and where individual needs differ, Ubuntu MATE is an excellent 
solution.

Preference settings for basic accessibility setting are found in the Control Center at System
> Control Center > Assistive Technology. From here you can enable assistive applications, 
change which visual and mobility applications are used by default, and even change 
whether they are started when your computer starts up. You can also modify your keyboard
(sticky keys, slow keys, bounce keys) and mouse (locate pointer, acceleration, sensitivity, 
drag & drop, double-click timeout) accessibility settings from here. You can even enable an 
on-screen keyboard if you need it. 

Ubuntu MATE has many keyboard shortcuts that, by pressing a combination of keys, help 
you do things that normally require a mouse, trackpad, or other input device that might also
require sight or muscular range of motion not possible for some computer users requiring 
accessibility. For some of these keyboard shortcuts, Ubuntu MATE makes use of a special 
meta key, the "Super" key, available on most computer keyboards. The Super key can be 
used to activate the menus/launchers and many keyboard shortcuts that include the Super 
key. Appendix A lists some common ones.

Note: On computer keyboards designed for use with the Windows operating system, the 
Super key is labeled with the "Windows" logo. On keyboards designed for use with Apple's 
operating system, the Super key is labeled as the "Command" key. On computers designed
for Linux, the Super key may be labeled with the Tux penguin logo (the Linux mascot), the 
Ubuntu logo, or perhaps even a blank square. When you order a computer pre-installed 
with Linux from the manufacturer Dell, you will need to follow Dell's instructions on how to 
enable the Super key. Details are available from Dell's support website in a knowledge 
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base article entitled, "How to enable the Ubuntu super key on Dell OEM Ubuntu 
installations."

Enabling Onboard and Orca at Startup

When Ubuntu MATE is first installed as your computer's operating system, it is pre-
configured so that both Orca, the screen reader, and Onboard, the on-screen keyboard, are
already installed and running in the background. All you need to do to use them is press the
keyboard shortcut detailed in each section below to turn the feature on. You use the same 
shortcut to turn each application off again.

If you want to use these features at the login screen, before Ubuntu MATE even starts, the 
accessibility icon in the upper right of the screen lets you toggle on and off Orca and 
Onboard. You can also use Orca's keyboard shortcut <Alt> + <Super> + S to enable the 
screen reader to assist in the login process.

Orca Screen Reader

The Orca screen reader is a free, open source, flexible, and extensible screen reader that 
provides you with access to the graphical desktop via user-customizable combinations of 
speech and/or braille. It is pre-installed in Ubuntu MATE for blind and low vision users. At 
the login screen, and after Ubuntu MATE starts, you toggle the screen reader off and on by 
pressing <Alt> + <Super> + S. 

With some other Linux distributions, getting Orca to work can be tricky. With Ubuntu MATE 
all the setup is done for you. It also works nicely with pretty much all of the pre-installed 
software, including the LibreOffice office suite and the Firefox browser. 

For complete information about using and configuring the Orca screen reader, refer to the 
website https://help.gnome.org/users/orca/stable/. 

The Orca documentation on the website occasionally refers to the "Orca Modifier" key. The
key that Orca uses by default as the "Orca Modifier" depends on whether you are using 
Orca's "Laptop" keyboard layout or its "Desktop" keyboard layout:

 If you are using the "Laptop" layout, the default Orca Modifier will be <CapsLock>.
 If you are using the "Desktop" layout, for the Orca Modifier you can use either the 

normal <Insert> key or the <KeyPad Insert>. <KeyPad Insert> is the same key as 
the 0 (zero) on the numeric keypad.

You can use the "Orca Modifier" key to get to Orca's help. Press <Orca Modifier> + H to 
enter "learn mode". 

 To view Orca's documentation, press <F1>.
 To hear a list of Orca's shortcuts, press <F2>.
 To hear a list of Orca's shortcuts for the current application, press <F3>.

To learn more about how to use Orca to read documents and websites, see the web page: 
https://help.gnome.org/users/orca/stable/#reading.

- 48 -

https://help.gnome.org/users/orca/stable/#reading
https://help.gnome.org/users/orca/stable/
http://www.dell.com/support/article/us/en/19/how12108/how-to-enable-the-ubuntu-super-key-on-dell-oem-ubuntu-installations?lang=en
http://www.dell.com/support/article/us/en/19/how12108/how-to-enable-the-ubuntu-super-key-on-dell-oem-ubuntu-installations?lang=en


You may find that the screen reader speaks too slowly or too quickly for you. You can 
adjust the rate at which Orca speaks, and make other adjustments as well, in Orca 
Preferences. To get to the Orca Preferences screens, press <Orca Modifier> + 
<Spacebar>. If you find yourself needing to adjust the speed frequently, you might want to 
bind (map) the "increase the rate" and "decrease the rate" commands to specific keys. That
way you can more easily make these adjustments. To review (and setup) the keyboard 
shortcuts and commands that Orca uses, you will want to refer to the documentation on key
bindings on this web page: 
https://help.gnome.org/users/orca/stable/howto_key_bindings.html.en. 

This is just a small sampling of the documentation that is available to you on the Orca site. 
Browse around. Discover what this powerful tool can do! 

Onboard On-Screen Keyboard

Onboard is the name of Ubuntu MATE's on-screen keyboard. Onboard is pre-installed in 
Ubuntu MATE and is available at the press of a few keys for anyone requiring the use of an
on-screen keyboard in place of a traditional hardware keyboard. In addition to supporting 
mobility-impaired users, Onboard provides support for tablet and touch-screen computers. 
To turn Onboard off or on again from the hardware keyboard, press <Alt> + <Super> + K. 

You can also enable Onboard so that it is available on-screen right at startup: 

1. Open the Assistive Technologies Preference tool, found at System > Control Center > 
Assistive Technology. 

2. Check the box labeled "Enable assistive technologies."

3. Click the Preferred Applications button. 

4. Select the "Accessibility" tab.

5. Check the box labeled "Run at start" and click Close.
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Additional settings and preferences for Onboard are listed in the Control Panel in the 
"Personal" section as "Onboard Settings". 
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Screen Magnifier

If you are a low vision user and you require screen magnification, Ubuntu MATE has two 
magnification options already built in. To turn on or off the default screen magnifier, press 
<Alt> + <Super> + M. Once you have the magnification turned on you can zoom into a 
portion of the screen by pressing <Alt> + <Super> + + (the plus key). To zoom out, press 
<Alt> + <Super> + - (the minus key). 

An alternative screen magnifier is available if you have the Compiz window manager 
enabled using MATE Tweak. Compiz is preconfigured to allow you to zoom in and out by 
scrolling while holding down the <Super> key. The Compiz screen magnifier is on and 
available at all times for you to use. No need to toggle the zoom function on and off. It 
zooms the entire screen at once, not just a small section of the screen. The zoomed screen
follows the motion of the mouse so that you can easily move around to any portion of the 
screen. For these reasons, I think it's a better screen magnifier.

To switch to the Compiz window manager, from the System menu, select Preferences > 
Look and Feel > MATE Tweak > Windows. For the window manager setting, select Compiz
(Advanced GPU accelerated desktop effects). Confirm the change when prompted. If the 
setting is unavailable, your hardware is not capable of the advanced acceleration required 
to use Compiz and the default screen magnifier is available. 
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Note: Onboard and Orca accessibility features and keyboard shortcuts remain fully 
available with Compiz enabled.
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MATE Applications

File Browser (Caja)

The Caja application, found in the Ubuntu MATE menus at Applications > System Tools > 
Caja, lets you organize and manage files and folders, both on your computer and on a 
home network. In Ubuntu MATE many things are files, such as word processor documents,
spreadsheets, photos, movies, and music. Caja lets you manage them all.

Using the file manager you can do the following:

 Create documents and folders.
 Display files and folders.
 Search for and manage your files.
 Run scripts and launch applications.
 Open special locations on your computer.
 Write data to a CD or DVD.
 Install and remove fonts.

Like file managers in other operating systems (Apple calls their file manager "the finder") 
Caja lets you organize your files into folders. Folders can contain files and even other 
folders. Some people find that organizing files into folders can help them locate their files 
more easily.
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As a user of Ubuntu MATE, you have a Home Folder. By default, it contains several folders
and any files that you create. Viewed from the Caja file manager, Desktop is just another 
folder in your Home Folder that can, itself, contain folders and files. When viewing the 
desktop showing your background wallpaper, Desktop can display special icons that allow 
easy access to your Home Folder, Trash, and removable media such as floppy disks, CDs, 
and USB flash drives. We saw how to enable these special desktop icons in the section 
"Create System Icons Using MATE Tweak", above.

The Caja file manager is always running while you are using the MATE desktop 
environment. To open a new Caja window, double-click on an icon on the desktop such as 
Home or Computer, or choose an item from Places menu on the top panel.

The file manager window is a file browser of sorts. Double-clicking the icon for a file opens 
the file in the Caja software application that lets you view and/or edit the document. 
Opening a folder by double-clicking on its icon updates the current file manager window to 
show the contents of the opened folder. You can also open a folder by right-clicking on that 
folder, then choosing between Open (this is the same as simply double-clicking the folder), 
Open in a New Tab, or Open in a New Window. 

In addition to the folder contents, the browser window displays a toolbar with common 
actions and locations, a location bar that shows the current location in the hierarchy of 
folders, and a sidebar that can hold different kinds of information.

For more information about how you can use Caja, and the various preferences that you 
can set, see the "Desktop User Guide" by pressing <F1> while Caja is open. 

MATE Calculator

The Calculator application can be found in the Ubuntu MATE menus at Applications > 
Accessories > MATE Calculator. It is a calculator with ordinary notation/reverse polish 
notation (RPN), a formula entry mode, different number bases (DEC, HEX, OCT, BIN) and 
different units of angular measure (DEG, RAD, GRAD). It supports quad-precision floating 
point and 112-bit binary arithmetic. MATE Calculator has four modes: Basic, Advanced, 
Financial and Programming. The Advanced mode is shown, below.
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For help topics on this application, see the Calculator manual by pressing <F1> while 
MATE Calculator is open. Topics include user interface, equations, number formats, 
conversions and financial calculations.
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Text Editor (Pluma)

The Pluma text editor, found in the Ubuntu MATE menus at Applications > Accessories > 
Pluma Text Editor, enables you to create and edit text files. The aim of Pluma is to be a 
simple and easy to use text editor. You can enable more powerful features with different 
plug-ins, allowing a variety of tasks related to text-editing. 

The Pluma window contains the following elements:

Menubar

The menus on the menubar contain all of the commands you need to work with files in 
Pluma. Note, if you have chosen a layout that uses the Global Menu, the menubar items 
will be displayed in the Global Menu rather than within the Pluma window. 

Toolbar

The toolbar contains icon buttons that represent a subset of the commands that you can 
access from the menubar.

Display area

The display area is where the text of the file you are editing is displayed.
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Status Bar

The status bar is at the bottom of the window and displays information about how you are 
using Pluma. The status bar display includes the following information:

Cursor position is the line number and column number where the cursor is located.

Edit mode is changed using the <Insert> key on your keyboard. If the editor is in insert 
mode, the status bar contains the text "INS." If the editor is in overwrite mode, the status 
bar contains the text "OVR." 

Side Pane

By default, the side pane is not shown. To show it, choose View > Side Pane.

The side pane displays a list of open documents and other information depending on which
plugins are enabled.

Bottom Pane

The bottom pane is used by programming tools such as the Python Console plugin to 
display output.

By default, the bottom pane is not shown. To show it, choose View > Bottom Pane.

When you right-click in the Pluma window, a popup menu appears containing the most 
common text editing commands.

Like other MATE applications, actions in Pluma can be performed with the menu, with the 
toolbar, or with keyboard shortcuts. See the appendix for a list of common keyboard 
shortcuts.

Creating a New Document

To create a new document, choose File > New. Pluma displays a new blank document in 
the display area.

Opening a File

If you have the Caja file manager open and you can see your file, simply double-click it, 
otherwise, to open a file, choose File > Open to display the "Open File" dialog. Navigate to 
the folder that contains your file, then select the file that you want to open and click Open. 
The file is displayed in the Pluma window. You can open multiple files in Pluma. The 
application adds a tab for each open file to the window above the display area. 

Saving a File

To save changes to a file you have opened and/or already saved, choose File > Save.

To save a new file or to save an existing file under a new filename, choose File > Save As. 
Enter a name for your file and click Save.

To save all of the files that are currently open in Pluma, choose Documents > Save All.

To close all of the files that are currently open in Pluma, choose Documents > Close All. If 
you have any open files with unsaved edits, you will be prompted to save them before that 
file is closed.
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Archive Manager (Engrampa)

You can use the Engrampa Archive Manager application, found in the Ubuntu MATE 
menus at Applications > Accessories > Engrampa Archive Manager, to create, view, 
modify, or unpack an archive. An archive is a file that acts as a container for other files. 
Sometimes referred to generically as "zipped files" or "compressed files," an archive can 
contain many files, folders, and subfolders, usually in compressed form. 

The most common archive format on UNIX and Linux systems is the tar archive 
compressed with a file name ending in "tar.gz" or "tar.bz." The most common archive 
format on Windows systems is the archive created with applications that generate archives 
with a file name ending with the ".zip" extension. Archive Manager supports all of these 
formats, and if you have the appropriate command-line tools installed, it will support many 
more.

The Archive Manager application window includes the following elements:

Menubar

The menus on the menubar contain all of the commands you need to work with files in 
Archive Manager. Note that if you have chosen a layout that uses the Global Menu, the 
menubar items will be displayed in the Global Menu rather than within the Archive Manager
window. 

Toolbar

The toolbar contains icon buttons that represent a subset of the commands that you can 
access from the menubar.

Using Archive Manager

To create a new archive file, you can choose Open from the menu, click and drag one or 
more files or folders from the Caja File Browser window into the Archive Manager window, 
or right-click one or more files in Caja and selecting Compress from the menu.

To expand a compressed file's contents, you start by opening the archive by double-
clicking it in the File Browser. Next, you can choose one or more files in the Archive 
Manager window and either choose Extract from the menu or drag them to the desktop or 
other location where you want the files to end up. 
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Image Viewer (Eye of MATE)

The Eye of MATE Image Viewer application, found in the Ubuntu MATE menus at 
Applications > Graphics > Eye of MATE Image Viewer, enables you to view single image 
files, as well as large image collections. 

The Image Viewer can open a wide variety of image file formats including animated 
graphics (ANI), bitmaps (BMP, PNG, ICO, PCX, WBMP, XBM, XPM), vector graphics 
(SVG), and other popular formats like JPEG, GIF, TIFF, and more. Files can be saved in 
BMP, ICO, JPEG and PNG formats.

Menubar

The menus on the menubar contain all of the commands you need to work with images in 
Image Viewer. Note, if you have chosen a layout that uses the Global Menu, the menubar 
will be displayed in the Global Menu rather than in the Image Viewer window. 

Toolbar

The toolbar contains icon buttons that represent a subset of the commands that you can 
access from the menubar.

Using Image Viewer

Image Viewer has features to help you view your images. You can zoom in and out or view 
the image full-screen. You can rotate and flip the image you are viewing.

The collection view allows you to view and edit large image collections. In this view, image 
operations can be applied to all selected images at once.

Image Viewer has special support for digital camera pictures and displays EXIF metadata 
recorded with the image. All modifications made in JPEG images are lossless. That is, 
saving rotated and flipped JPEG images will not recompress the image. Beside this, all 
available metadata (like EXIF) will be preserved and updated accordingly.

For help topics on this application, see the Image Viewer manual by pressing <F1> while 
the Image Viewer is open. 
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Document Viewer (Atril) 

The Atril Document Viewer, found in the Ubuntu MATE menus at Applications > Office > 
Atril Document Viewer, enables you to view documents of various formats like Portable 
Document Format (PDF) files, PostScript files, and e-book (EPUB) files. 

You can open the Atril Document Viewer from the menus, or more simply by double-
clicking on the file you want to open in the Caja file manager. To zoom in and out, you can 
use the keyboard shortcuts <Ctrl> + + (the plus key) and <Ctrl> + - (the minus key). You 
can also hold the <Ctrl> key while scrolling the mouse wheel, or you can use the on-screen
button to select from some preset zoom levels including "Fit Page Width" and "Best Fit" 
among others.

Menubar

The menus on the menubar contain all of the commands you need to work with documents 
in Atril. Note, if you have chosen a layout that uses the Global Menu, the menubar items 
will be displayed in the Global Menu rather than within the Atril window. 

Toolbar

The toolbar contains icon buttons that let you navigate the document by page and change 
the zoom factor.
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Left Navigation Pane

Depending on the type of file you are opening, the left pane of the Atril window may show 
an index, bookmarks, an outline, or annotations. Clicking the header lets you switch 
between them. You can navigate the document page by page, by scrolling with your 
mouse, or by using the left pane to jump to a topic.

For help topics on this application, see the Atril manual by pressing <F1> while Atril 
Document Viewer is open. Topics include printing, copying, and working with password-
protected documents.

MATE Disk Usage Analyzer

The MATE Disk Usage Analyzer, found at Applications > System Tools > MATE Disk 
Usage Analyzer, is a graphical tool for analyzing how your storage media is being used. It 
can scan the entire file system on a disk or in a specific folder. It provides a graphical 
treemap window for each selected disk or folder. 

Menubar

The menus on the menubar contain all of the commands you need to work with the disks 
and file system in Disk Usage Analyzer. Note, if you have chosen a layout that uses the 
Global Menu, the menubar items will be displayed in the Global Menu rather than within the
Disk Usage Analyzer window. 

Toolbar

The toolbar contains icon buttons that represent a subset of the commands that you can 
access from the menubar.
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MATE System Monitor

The MATE System Monitor, found in the Ubuntu MATE menus at Applications > System 
Tools > MATE System Monitor, enables you to display basic system information and 
monitor system processes, usage of system resources, and file system usage. You can 
also use MATE System Monitor to modify the behavior of your system. 

The "System" tab shows information about the computer's hardware and software, as 
shown above. The "Processes" tab, shown below, shows information about active 
processes (applications, utilities, etc.) and how they relate to each other. You can stop, 
end, or kill a process or otherwise control active processes.

The "Resources" tab displays current CPU, memory, and network usage. "File Systems" 
lists all mounted file systems and basic information about each. For help topics on this 
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application, see the MATE System Monitor manual by pressing <F1> while MATE System 
Monitor is open.
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MATE Terminal

MATE Terminal is a terminal emulation application that can be found in the Ubuntu MATE 
menus at Applications > System Tools > MATE Terminal. It provides access to the powerful
Linux command line and interprets and executes the commands that you type at a 
command-line prompt. 

Although the MATE Terminal can be used to launch graphical applications by simply typing
the name of the application and pressing the Enter key, you normally use it to run 
applications that are not designed to be run as graphical applications. These text-based 
applications, known as command-line programs, can be used to create scripts and other 
programs, get and install additional software from the software catalog, check the status of 
your computer's hardware and installed software, and many, many other things. In fact, 
years before graphical applications were made popular for computing, computer users 
checked email, communicated with other computers, shared files, photos, and programs, 
and even browsed early versions of the Internet from terminal applications very similar to 
the MATE Terminal. 

As an example of how to use the command line, let's look at the apt application. It is a 
powerful command-line tool which can be used to install new software packages, upgrade 
existing software packages, update the package list index, and even upgrade the entire 
Ubuntu MATE system. 

It's good practice to ensure that you have the latest changes made in the Ubuntu software 
repositories before installing software. The apt command can be used to update the index 
of available software packages that is on your computer. To do this, type the following in 
the terminal window:

sudo apt update

Note: When you use "sudo" you are telling Linux that you want to run the command as 
administrator, so for security purposes, you will be asked for your password the first time 
you use "sudo" in a terminal session.

Also note that what you type in the terminal is case-sensitive. "Install" is not the same as 
"install." As far as the terminal is concerned, they are two entirely different words.

Installing software using the apt tool is quite simple, provided you know the name of the 
application, and provided it is available in the software catalog. For example, to install the 
audio recording and editing application Audacity, type the following into a terminal window 
at the command prompt:

sudo apt install audacity

To uninstall (remove) an application is just as easy. To remove the Audacity application 
installed in the previous example, type the following:
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sudo apt remove audacity

Adding the "--purge" option to "apt remove" will remove the package configuration files as 
well. This may or may not do what you want, so use it with caution. Here's how that looks 
using our same example:

sudo apt remove --purge audacity

Over time, updated versions of packages currently installed on your computer may become
available from the package repositories. To use the command line to upgrade the 
applications on your system, first update the package index:

sudo apt update

When that command has finished running, type the following to complete the upgrade:

sudo apt upgrade

How to use terminal and command-line programs is a topic that has been explored in many
books, so I won't go into more detail here. One popular and excellent book on this topic is 
"The Linux Command Line: A Complete Introduction" by William E. Shotts Jr. 

Another source of information on using the terminal is the MATE Terminal manual 
contained within the MATE Desktop User Guide. It's provided with Ubuntu MATE. To go 
there directly, open the MATE Terminal application from the menu, then press the <F1> 
key on your keyboard to open the manual.
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Control Center

The Control Center provides you with a single window that houses all of the major Ubuntu 
MATE preference tools. These tools let you tweak the way things look and behave, 
manage software updates, and make adjustments to the printing system, among other 
things. 

Simply click the icon for the preference you want to adjust. Each of these preferences are 
also available under the System > Preferences menu. The sub-menus correspond to the 
Groups in the Control Center. 

You'll also find many of the settings and selections you can make from within the Ubuntu 
MATE Welcome application are also available in the Control Center. The Control Center 
simply provides a central point from which you can adjust almost any system-level setting 
for your Ubuntu MATE computer.
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Productivity Applications
Many of the applications you would expect to find installed on a modern computer are 
provided, pre-installed on Ubuntu MATE. If you don't find an installed application to do what
you want to do, you'll likely find it in the Software Boutique or using one of Ubuntu MATE's 
other software management applications, and install from there. See the "Adding Trusted 
Applications" section above for more information about installing software.

Unlike with Windows and macOS, Ubuntu MATE provides you with all of the pre-installed 
applications at no charge. And the vast majority of the software available in the software 
repositories is also free of charge. Here is a sampling of some of the productivity 
applications you'll find as soon as you start using Ubuntu MATE.

Firefox Web Browser

Pre-installed with Ubuntu MATE, Firefox is a popular application on almost any computing 
platform that delivers safe, easy web browsing. A familiar user interface, enhanced security
features including protection from online identity theft, and integrated search let you get the 
most out of the web. Firefox also provides features such as changing your home page, 
searching the web, bookmarking a site, and using a private browsing mode. You can also 
synchronize your Firefox bookmarks, history, passwords and more between your devices. 

For additional help with Firefox, go to the Firefox help site at 
https://support.mozilla.org/products/firefox. 

Thunderbird Email Client

Web-based email programs that come from your Internet service provider (ISP) and 
Internet mail systems like Yahoo Mail and Google's Gmail are convenient to use because 
they allow you to read and send email from any device. The only thing you need to run 
these is a web browser and an Internet connection. Many ISPs provide email clients that 
you can use to read and respond to your email off-line as well. Unfortunately, those off-line 
programs are usually applications for Windows. Many ISPs also give you the option of 
using their online email in conjunction with almost any computer-based email client that can
handle POP mail or IMAP mail. Thunderbird is a cross-platform email client that works on 
Linux and macOS as well as on Windows.

Thunderbird is a full-featured email, RSS, and newsgroup client that makes emailing safer, 
faster and easy. It supports different email accounts (POP, IMAP, Gmail), has a simple 
email account setup wizard, one-click address book, tabbed interface, an integrated 
learning spam filter, advanced search and indexing capabilities, and offers easy 
organization of emails with tagging and virtual folders. 
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If you use the automatic account configuration, setting up a new account with Thunderbird 
is easy. All you need to do is provide your username and password for your email provider 
and your email address. Thunderbird works very nicely with Gmail and even synchronizes 
messages between Thunderbird on your computer and Gmail. 

For additional help with how to setup and use Thunderbird mail, go to the Thunderbird help 
site at https://support.mozilla.org/products/thunderbird.

LibreOffice Office Productivity Suite

LibreOffice is a full-featured office productivity suite that provides a near drop-in 
replacement for Microsoft's office suite and is compatible with Google's online office suite. 
Like many office suites, LibreOffice includes several applications, but unlike other suites, it 
contains applications like Base and Math, as a basic part of the suite. LibreOffice is also 
truly full-featured, unlike the online versions of office productivity apps that provide only the 
basic functions most people use. Basic capabilities are fine until you need to use one of 
those "advanced" features. Then you'll be looking for something with all the features.

 Writer, the word processor. 
Compare with Microsoft Word and Google Documents.

 Calc, the spreadsheet application. 
Compare with Microsoft Excel and Google Sheets.

 Impress, the presentation engine. 
Compare with Microsoft PowerPoint and Google Slides.

 Draw, the drawing and flowcharting application. 
Compare with Microsoft Visio and with inserting a drawing into a Google Doc.

 Base, the database and database front end. 
Compare with Microsoft Access.

 Math, for editing mathematic formulas. 
Compare with Microsoft Equation editor and the Auto-Latex Google Docs add-on.

The Document Foundation (the organization behind LibreOffice) maintains an excellent set 
of documentation online for LibreOffice at https://documentation.libreoffice.org
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Bluetooth Connectivity

Ubuntu MATE provides the software you need to support Bluetooth connections to 
headphones, mice, keyboards, or other computing devices. 

Connecting Devices (Pairing)

In order to use a Bluetooth device like a mouse or a headset, you first need to connect 
(pair) your computer and the device. Before you begin, make sure Bluetooth is enabled. 
Some computers allow you to disable Bluetooth from BIOS/UEFI. Check your BIOS 
settings to ensure that, if you have this setting, Bluetooth is enabled. Some laptops have a 
function key or other button that toggles Bluetooth and/or Wifi on and off. If your computer 
has this capability, make sure that Bluetooth is enabled in that way as well.

1. Right-click the Bluetooth icon in the upper panel and select Set Up New Device.

2. Make the other Bluetooth device discoverable or visible and place it within 30 feet 
(about 10 meters) of your computer. Click Continue. Your computer will begin 
searching for devices.

3. If there are too many devices listed, use the Device type drop-down to display only a 
single type of device in the list.

4. Click PIN options to set how a PIN will be delivered to the other device.

Note: The automatic PIN setting will use a six-digit numerical code. A device with no input 
keys or screen, such as a mouse or headset, may require a specific PIN such as 0000, or 
no PIN at all. Check your device's manual for the proper setting.

5. Choose an appropriate PIN setting for your device, then click Close.

6. Click Continue to proceed. If you did not choose a preset PIN, the PIN will be 
displayed on the screen.

7. If required, confirm the PIN on your other device. The device should show you the PIN
you see on your computer screen or may prompt you to enter the PIN. Confirm the 
PIN on the device, then click Matches.

Note: You need to finish your entry within about 20 seconds on most devices, or the 
connection will not be completed. If that happens, return to the device list and start again.

8. A message appears when the connection successfully completes. Click Close.
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Synergy

Synergy is a magical, cross-platform application that allows you to use the keyboard and 
mouse from one of your computers, to control and interact with the desktops of other 
computers on the same network. Synergy is one of my favorite utilities. Although it's not 
pre-installed with Ubuntu MATE, it is available in the software repositories. Synergy is an 
example of software for Linux that is not free of charge. Your one-time fee provides a 
license for personal use on all of your computers. For corporate use, there is a monthly fee.
Details are on the website.

With Synergy's graphical, drag and drop setup, you can be controlling multiple Linux,
macOS, and Windows computers in seconds. For example, if the keyboard and mouse are
connected directly to your Ubuntu MATE computer, you will be using them to control both

your Ubuntu MATE computer and other Linux, macOS or Windows computers. You can set
up and control up to 14 client computers running a mix of Windows Vista through 10,

macOS 10.9.X and newer, Red Hat Linux REHL 6 and 7, Ubuntu (and derivatives) 12.04
LTS and up, and Debian. You will need to purchase a license for any non-Linux computers.
It's available at https://symless.com/synergy. Once you have purchased a license, you can
use that same license on multiple computers. Look for the support article, "Getting Started

with Synergy" for instructions on how to install and configure Synergy to work with your
computers. This is truly a productivity tool!

Update: As I write this book, Synergy 2 has been announced. Projected to be available in 
November 2017, this new version is promising automatic setup, automatic updates, always 
running in the background, and share any keyboard and mouse on all computers. 
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Caffeine

With a coffee cup for an icon, Caffeine is a status bar application which sits in the panel 
near the clock and prevents the desktop from becoming idle. Simply right-click on the icon 
and choose "Activate" to temporarily prevent the activation of both the screensaver and the 
"sleep" power saving mode. Right-click the icon again and choose "Deactivate" to go back 
to normal. 

Caffeine is not installed out-of-the-box with Ubuntu MATE, but it is available at no charge in
the Software Boutique for one-click installation.
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Document Management
Ubuntu MATE makes printing, scanning and saving documents almost easier than creating
them. All the software you are likely to need is pre-installed for most popular printers and 
scanners, so setting up your hardware is easy, too.

Printing

Printing on Ubuntu MATE is simple and easy. The most popular printer drivers are already 
provided in Ubuntu MATE's Linux kernel. In most cases you simply connect your printer via 
its USB cable and Ubuntu MATE immediately configures it for use. There is nothing to do 
but start printing. 

If you need to configure a network (or wireless) printer manually, you can follow these 
simple steps. Before you start, ensure that the printer is turned on and connected to the 
same network as your computer.

1. Open the Printers application at System > Administration > Printers. 

2. Click Add. 

3. Click on Network Printer to view the network printers automatically detected by 
Ubuntu MATE.

4. Select the printer from the list and click Forward. Note that a driver has been 
automatically selected for you. If your printer driver is not automatically selected, you 
can select the manufacturer and the model from the database of drivers when 
prompted.

5. On the next screen, you can accept the suggestions provided or you can name your 
printer, give it a long description and even name its location.

6. Click Apply to complete the configuration.

7. Print a test page to verify the setup and you are ready to begin using your network 
printer.

Advanced Printing Utility

For added control, you can install the HP Linux Imaging and Printing (HPLIP) utility from 
the Ubuntu MATE Welcome application or from the Software Boutique. It gives you access 
to additional drivers and provides more options for managing your printers. For inkjet 
printers, as long as your printer supports it, you can monitor ink levels and printer status, 
you can change page size and print quality, and you can even clean the print heads. For 
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multi-function devices, you can change fax header information and other settings for the fax
functionality. Scanning functions are supported by the separate Simple Scan application 
described in the next section.

To learn more about the HPLIP toolbox, see the web page for the utility at 
http://hplipopensource.com/hplip-web/about.html. 
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Scanning

The Simple Scan application, found in the Ubuntu MATE menus at Applications > Graphics
> Simple Scan, provides a simple and easy way to scan your documents. Once your 
scanner is connected via USB or over the network, the configuration is usually automatic. 
Using Simple Scan is as easy as: load your document, press Simple Scan's Scan button, 
then save the image. For more information about how to use Ubuntu MATE's more 
advanced scanning capabilities, view the "Simple Scan Manual" by pressing <F1> while 
Simple Scan is open. 

PDF Creation

Whether you are scanning a page, writing a book, or saving a web page, you sometimes 
need to make a PDF file from a document. You don't need a special application with 
Ubuntu MATE. PDF creation is built-in. Most applications provide a menu selection to Save
As PDF or Export to PDF. If the application you use does not offer one of those options, 
Ubuntu MATE provides the ability to print a document or file in PDF format. See the 
illustration.
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Entertainment
Ubuntu MATE comes pre-installed with three significant applications for managing your 
entertainment and media files and subscriptions. If you need more, the software 
repositories offer much, much more to choose from.

Rhythmbox Music and Podcast Manager

Rhythmbox, found in the Ubuntu MATE menus at Applications > Sound & Video > 
Rhythmbox, is a very easy to use music playing and management program which supports 
a wide range of audio formats (including MP3 and ogg). Originally inspired by Apple's 
iTunes, Rhythmbox is much easier to understand and use, and it supports Internet Radio, 
iPod integration and generic portable audio player support, audio CD burning, audio CD 
playback, music sharing, and podcasts. 

Subscribe to a podcast with Rhythmbox

1. Click Podcasts in the Rhythmbox's left panel.

2. Click the Add button in the button bar. The search panel opens.

3. Type a search term or you can type or paste the link for the podcast feed into the 
search field.
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4. Click Search. Podcasts matching your search appear in a list below the search.

5. Select the podcast you want from the list and click Subscribe. The episodes are 
added to the playlist and Rhythmbox immediately begins downloading the latest 
episode into a folder named for the podcast within your Music folder. Rhythmbox 
checks periodically for new episodes of each podcast and downloads them for you.

6. Click Close to hide the search panel.

To play an episode, select one from the list and press the Play button. You may wish to 
click on the header of the Date field to sort the episodes so that the latest episode is at the 
top of the list. As long as you have an Internet connection, you can play any of the older 
episodes without downloading them. Right-click any episode in the list to see an option to 
download that episode.

For more information on how to use the playlist and other features of Rhythmbox, see the 
"Rhythmbox Music Player Manual" by pressing <F1> while Rhythmbox is open. 

Shotwell Digital Photo Organizer

Shotwell, found in the Ubuntu MATE menus at Applications > Graphics > Shotwell, is a 
digital photo organizer. It allows you to import photos from disk or camera, organize them in
various ways, view them in full-window or full-screen mode, and export them to share with 
others. It is able to manage photos in many different image formats, also including raw CR2
files.

When you first launch Shotwell, it scans your computer for photos and imports them so that
you can use Shotwell to organize them. Once you have all the photos from your computer's
hard drive within Shotwell, you can import new files by choosing File > Import From Folder 
from the menus, or by dragging and dropping them onto the Shotwell window, or by 
connecting a camera to your computer and choosing to import the photos from there. 

With Shotwell, you have several features to help you organize your photos. You can group 
photos that were taken at the same time into events, then rename, merge and sort events. 
Flag photos to mark them as special, or to work with them as a set. You can also search 
for, rate, tag, and title your photos.

Shotwell also provides the ability to edit the photos themselves. You can change the date 
and time of photos where they are incorrect, crop photos, remove red-eye, auto-enhance to
improve brightness and contrast, rotate or flip a photo, and even straighten photos taken at 
an angle.

Of course, you can share your photos from Shotwell by exporting or printing them. You can
also publish them to Facebook or other online sites, send them via email or instant 
messaging, or simply display them as a slideshow.

To learn more about how to use each of the features of Shotwell, see the "Shotwell Photo 
Manager Manual" by pressing <F1> while Shotwell is open. 
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VLC Media Player

VLC, found in the Ubuntu MATE menus at Applications > Sound & Video > VLC media 
player, is the VideoLAN project's cross-platform media player that can play almost anything
you throw at it! It plays MPEG, MPEG-2, MPEG-4, DivX, MOV, WMV, QuickTime, WebM, 
FLAC, MP3, Ogg/Vorbis files, DVDs, VCDs, audio and video podcasts, and multimedia 
streams from various network sources. VLC can also be used as a streaming server that 
duplicates the stream it reads and multi-casts it through the network to other clients, or 
serves it through HTTP. 

VLC has support for on-the-fly transcoding of audio and video formats, either for 
broadcasting purposes or for movie format transformations. That means you can convert 
video files from one format to another or take almost any audio or video file in any of the 
supported formats and make it into an MP3 or other audio file.

For additional information about VLC and how it works, see VideoLan's VLC Introduction 
video at https://wiki.videolan.org/Documentation:VLC_for_dummies, or press <F1> while VLC is 
open. 
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Security

The Linux operating system is more secure, and better supported than the operating 
systems pre-installed on most home computer hardware today. Linux is backed by many 
large corporations, as well as independent developers and users, many of whom are 
focused on ensuring and improving the security that is built into the operating system. The 
built-in updater provided with the Ubuntu MATE distribution of Linux provides security 
updates for both its software applications and the operating system. Vulnerabilities are 
patched more quickly and are delivered automatically and more frequently than the two 
most popular operating systems.

Unlike operating systems that update only once a month, Ubuntu MATE receives updates 
continuously. The updates include security patches for Ubuntu MATE and its installed 
applications and are all provided on the same frequent schedule. This ensures that you 
have the latest protection for all of your computer's software -- as soon as it's available!

Ubuntu MATE is designed to make it difficult for viruses, rootkits, and other malware to be 
installed and run without conscious intervention by you, the user. Ubuntu MATE users are 
not administrators by default. Administrators ("root" users) on any computer system have 
permission to do anything they want, including doing damage to the system. To be extra 
secure, Linux requires you to provide your administrator password to install or run 
programs as root. Every single time.

Basic Linux Security Guidelines

Canonical lists fewer than 30 Linux viruses and worms in its published malware list. In 
contrast, there are about 140,000 viruses for Windows, so...

 If you dual-boot with Windows, run Windows in a VM, use WINE or simply share 
files with Windows-using friends, scan the files for viruses.

 Enable the Ubuntu MATE software firewall, if it isn't already. (See below.)
 Keep your system updated. Updates are automatic on most Linux distributions. Let 

them run as soon as they are available.
 Use strong passwords. On everything. And use a secure password manager to 

store them.
 Make backups regularly.
 Install software only from trusted sources, like Ubuntu MATE's Software Boutique or

software repositories.
 Use security-related plugins for your Internet browser that protect your data, 

credentials, and privacy.
 Use your common sense. The biggest security threat is generally found between 

keyboard and chair.
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Backups (Déjà Dup)

Ubuntu MATE comes pre-installed with a Backup utility called Déjà Dup. Reinstalling an 
operating system again after something goes horribly wrong is annoying at best, but losing 
your photographs, emails, and personal documents can be a devastating loss of priceless, 
irreplaceable valuables. Backing up the information on your hard drive on a regular basis is 
critical for anyone who uses a computer routinely. You have spent hours on end producing 
the information that is on your hard drive. You should routinely back up at least your new 
data files on a weekly basis. "Data" files include databases, documents, spreadsheets, etc. 
Anything YOU created, imported, or downloaded onto your hard drive is a data file.

If you are prepared to restore from a backup, then you are far more secure. It is important 
to make backups right before performing certain risky operations like upgrading to a new 
operating system version, moving a large number of files around, deleting files and folders, 
etc. Déjà Dup even lets you automate your backups for added convenience and safety. 

In the event that your computer has a digital disaster, or you are concerned that it has an 
infection, your backups will ensure that you can restore Ubuntu MATE to a known 
previously good state. For example, making backups a routine can allow you to delete files 
and folders encrypted by ransomware and replace them with safe copies from your backup.

How Do I Know What & Where To Backup?

When I first started writing about backups, years ago, the only realistic way to perform a 
backup on a home computer was to save the data onto CDs, DVDs, Zip Drives, Jaz Drives 
or (worse still) floppy disks! Today, your best option is to use online storage or an external 
hard drive. Here, I'll focus on making backups to hardware devices. If you don't have a 
network attached storage (NAS) drive on your home network, you can readily purchase an 
external drive with multiple terabytes (TB) of storage capacity, or even an inexpensive 
portable USB external drive with a terabyte or more of storage -- large enough to hold the 
data from most computers' hard drives today.

On a typical recordable CD you can store up to 700 megabytes (MB) of information while 
DVDs can store up to 8.4 gigabytes (GB). Blu-ray discs are a more recent type of optical 
media. They can hold up to 50GB of data. With the size of files these days, you might get 
one or two video files on a DVD. If you have a file that is larger than 700MB, like a 
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moderate LibreOffice Impress presentation file, or a Writer document with graphics, an 
ordinary CD has no hope of holding even one whole file.

When backing-up data files, it is not always necessary to backup every file you have on 
your hard drive, although it's a good idea to do so monthly. (See below.) On your Ubuntu 
MATE computer, few files, if any, outside of your "home" folder need to be backed-up at all.
If a disaster were to happen, and you lost your computer or your hard drive, you could 
simply reinstall the Ubuntu MATE operating system and your applications in well under an 
hour, then restore the backed-up contents of your "home" folder. Your "home" folder 
contains the information that you have created yourself, including your mail file, and the 
settings and preferences for most of your applications. 

If you have a home network you may be lucky enough to own a multi-terabyte hard drive 
accessible to any computer on the network. Large external hard drives have become so 
inexpensive that it is wise to include an external hard drive in your budget when you are 
buying a new computer. In the illustration above, I am using Ubuntu-MATE's Caja file 
manager to take my entire "home" folder and copy it to an external 3TB NAS drive shared 
on my network.

Instead of being stored on your computer's hard drive, the files you copy to an external or 
networked drive are stored safely off of your computer. That way, if something happens to 
your computer's internal hard drive, or if you have your laptop stolen, all your files are 
safely stored on an external device.

An equivalent to a network drive (well, sort of...) is an online (off-site) storage service like 
Dropbox, Box, Google Drive, or SpiderOak. The advantage to this kind of backup is that 
your files are stored on the Internet. Even if the worst were to happen, and you lost 
everything to a fire or flood, your backups would be safe. And if you copy your files to 
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online storage, you will also likely be able to access them from another computer, a tablet 
or smartphone!

Backing up Your Computer Is Cheap Disaster Recovery Insurance

As I've mentioned, one way to backup inexpensively is to get a large firewire or USB 3.0 
external hard drive and copy everything in your "home" folder to it on a regular basis. And 
perhaps the easiest way to ensure that you make your backups regularly is to automate the
process using the backup software that comes pre-installed with Ubuntu MATE.

At least monthly, you should make a complete backup of everything important on your hard
drive either by using backup software, or by simply copying to a second hard drive or a 
network drive. Linux applications such as the pre-installed Ubuntu MATE Backup (Déjà 
Dup) application can automate these backups for you. You do this so that if your computer 
or hard drive were to be stolen, destroyed or damaged beyond repair, you would have a 
"disaster recovery" copy. From a "disaster recovery" copy, you could restore your entire 
"home" folder to the condition it was in, at the time of your last backup. If you do such a 
complete backup monthly, the worst case would be that you would have to restore less 
than a month's worth of additional data from your incremental data backups. (Incremental 
backups contain only what has changed since your last full backup.) 

How often should I backup?
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In reality, how often you should backup depends on several factors. In general, the more 
you use your computer or the more critical the work you are doing, the more often you 
should backup.

As a general guideline, you should use the external drive and/or your online storage to 
make a complete backup of your entire hard drive every month. So that you don't forget, 
automate the process using the backup software pre-installed with Ubuntu MATE. You can 
even set up the Backup application so that it copies only new files, and updates new 
versions of files on your computer to the backup device, never deleting anything from the 
copy. What a lifesaver that can be!

Use an online service or external hard drive to make a monthly full backup. In addition, 
each week you should back up your critical data files in an incremental backup onto your 
external storage, or to your online storage. Incremental backups can be automated, too.

Don't wait. Setup a scheduled backup right now -- or you will wish you had!

Software Updater

The Software Updater available from the Ubuntu Welcome app or from the menus at 
System > Administration > Software Updater, is the update manager for your system. 
Ubuntu MATE periodically checks to see if new software and security updates are available
for your computer. The updates are for Ubuntu MATE, all of its components, and all of your 
installed applications. This ensures that you have the latest updates and protection for all of
your computer's software as soon as it's available, not just once a month like other 
operating systems. 
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Using the Software Updater

After you launch the Software Updater from the menus, if updates are available, the 
application lists the updates and asks if you want to install them now. Click Install Now to 
begin the download. The dialog shown below appears while the update is in progress and 
another appears once the update is complete.

Managing the Updates

You have control over when and how software updates occur. Use the Settings button on 
the Software Updater screen, or from the menus, choose System > Administration > 
Software & Updates, the select the "Updates" tab. 

These are your options for controlling updates to Ubuntu MATE and its applications:

 You can choose from options to install "Important," "Recommended," 
"Unsupported" or any combination of these updates. 

 You can have the updater automatically check for updates every day, every two 
days, every week, every two weeks, or turn off automatic checking altogether. 

 You can have the updater automatically download and install security updates, 
download but not install them or simply display the updates so you can choose 
whether to download and install. 

 For other updates (other than security updates) you can choose to display available
updates as soon as they are available, weekly, or every two weeks. 

 You can also choose to be notified whenever there is a new release of Ubuntu 
MATE, only when there is a Long-Term-Support (LTS) release, or never.

- 84 -



Firewall

Ubuntu MATE's Firewall Configuration utility (Gufw), found in the Control Center at System 
> Control Center > Firewall Configuration, provides an uncomplicated way to manage your 
firewall settings. The firewall is not enabled by default in Ubuntu MATE because by default, 
Ubuntu MATE does not open ports to the outside world. 

If you do choose to enable the firewall, and if you are a normal (non-administrator) user, 
you will be safe with these settings:

 Status = On 
 Incoming = Deny
 Outgoing = Allow 

There is no need to set the firewall to autostart. After you change the settings they will take 
effect immediately and remain in place until you change them again. 
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Appendices

Appendix A: Keyboard Shortcuts
Ubuntu MATE has many keyboard shortcuts that, by pressing a combination of keys, help 
you do things that normally require a mouse, trackpad, or another input device. I've 
compared these keyboard shortcuts with those you might have used in your previous 
operating system. Note: Changing your theme or window manager in the MATE Tweak tool
might change some of these shortcuts. I've tried to indicate these changes in behavior in 
the notes and tables that follow.

Every major operating system makes use of a special hardware "meta key" on the 
keyboard. They are listed below, and for the purpose of running Ubuntu MATE on your 
computer hardware, the keys are equivalent with one another. 

Your keyboard's meta key can be used by Ubuntu MATE to activate menus and launchers 
as well as the many keyboard shortcuts that include the Super key. The MATE Dock 
Applet, used in the Mutiny layout, includes the ability to launch or switch to docked items 
based on their position in the dock using <Super> + 1, <Super> + 2, and so on. This will be 
familiar to users switching to Ubuntu MATE from Ubuntu's Unity 7 Desktop. As they are for 
users of the MATE Desktop in other Linux distributions, both the <Super> + L and the 
<Ctrl> + <Alt> + L key combinations are recognized as screen lock keyboard shortcuts in 
Ubuntu MATE. 
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Common Application Shortcuts

These shortcuts apply in most applications.

Ubuntu MATE Special Shortcuts
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Window Shortcuts
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Desktop Shortcuts

These are shortcuts you can use to operate parts of the desktop.

Compiz Effects Shortcuts

All of these shortcuts apply when the Compiz Window Manager is selected in the MATE 
Tweak tool.
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Appendix B: Additional Resources
If you need a little advice on how to get started with Linux, or how get better with it, the 
Going Linux website and podcast are designed to help you discover what you need to know
to do just that. Whether you enjoy reading about tips and tricks or listening to a couple of 
users like yourself, you'll find these resources a refreshing alternative to similar commercial 
offerings that are more formal and less friendly. As a new Linux user, you'll have a friendly 
way to learn what you need to improve your competence with the software. As a more 
experienced user, you'll improve your confidence with Linux and its applications. As an old 
hand at Linux, you'll discover new ideas, solve problems and have a reference for helping 
yourself and others with day-to-day use of the operating system.

Going Linux 

If you learn best by reading, or you are simply interested in using our services as a 
reference, visit our website at http://goinglinux.com, read our articles and/or download our 
brief Ubuntu MATE User Guide.

If you learn best by hearing others discuss interesting topics in an everyday conversational 
way, subscribe using iTunes, Stitcher, Rhythmbox, or other application that lets you receive
podcasts. http://subscribe.goinglinux.com. 

If you learn best by seeing videos on how to do something, then check out our screencasts 
at http://screencasts.goinglinux.com. 

If you are looking for an introduction to switching from other operating systems to Ubuntu 
MATE, you can order a paperback copy or download an ebook version of the book Ubuntu 
MATE: Upgrading from Windows or OSX.
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